any ROM i try ends up in error 7

pollo

New Member
Sep 5, 2017
7
2
3
#1
i've tried:
AEX 5.7 and 5.6 and 5.5 --> gets 90% done end then ERROR7
RR 6.1 --> starts with ERROR7
Discovery rom -->starts with ERROR7 and when i make it go to 100% it gets stuck in boot with discovery logo
dotOS --> ERROR7 every time, (invalid arguments )

i thought that using QFILwas going to help but no, i got back to stock zui then unlucked TWRP again but i'm still stuck in only using jaguar, not so bad, just worried about whats going on with my phone

(i've already tried deleting the asserts part of the respectives updater scripts) but i still get the error 7 at some point.
i'm using TWRP 3.3. something

please understand that i'm a noob and be patient with me :c
any help regarding this will be much appreciated
-------------------------------------------------------------------------------------------------------------------
just flashed stock zui 1.9 and tried one more time to flash any custom rom , but this time whenever twrp makes it to 100% (halve the time) and i try to restart the phone it opens the bootloader directly unable to start the phone.

just managed to flash DEODEX from zui 3.7.. and i think i'll stay here for a while
i'm still curious about why i can't flash other custom ROMs tho...
 
Last edited:

Zlatin

New Member
Feb 9, 2018
1
0
1
#2
i've tried:
AEX 5.7 and 5.6 and 5.5 --> gets 90% done end then ERROR7
RR 6.1 --> starts with ERROR7
Discovery rom -->starts with ERROR7 and when i make it go to 100% it gets stuck in boot with discovery logo
dotOS --> ERROR7 every time, (invalid arguments )

i thought that using QFILwas going to help but no, i got back to stock zui then unlucked TWRP again but i'm still stuck in only using jaguar, not so bad, just worried about whats going on with my phone

(i've already tried deleting the asserts part of the respectives updater scripts) but i still get the error 7 at some point.
i'm using TWRP 3.3. something

please understand that i'm a noob and be patient with me :c
any help regarding this will be much appreciated
-------------------------------------------------------------------------------------------------------------------
just flashed stock zui 1.9 and tried one more time to flash any custom rom , but this time whenever twrp makes it to 100% (halve the time) and i try to restart the phone it opens the bootloader directly unable to start the phone.

just managed to flash DEODEX from zui 3.7.. and i think i'll stay here for a while
i'm still curious about why i can't flash other custom ROMs tho...
I got the same Error on both of my Zuk's
 

DarkWinterCloud

Well-Known Member
Jan 20, 2017
706
308
63
Brasil
www.profixstore.com.br
#3
Error 7 is a common error. Means User error :)

Jokes apart, it can be a couple of reasons:

1- Wrong rom for your device (check variants, Z2 Plus models have unified roms, while Pro or Edge will not flash)
2- Bad downloaded file (corrupted file due to bad connectivity. Thats why some devs share the Hash number of the file, to check the integrity)
3- outdated TWRP
4- incompatible file system format (check if its EXT4 or F2FS, in any case, format again your internal storage to EXT4 since its the default)
5- in much rarer cases, you may have a problem with some internal partitions that cant be moded due to lack of permission (did you check the "allow modifications" box and swipe to enable TWRP to make changes in partitions when first entering the custom recovery?)

Solutions:
Start everything from scrach.
1- Flash latest ZUI
2- Unlock bootloader again
3- Flash latest TWRP from official site: https://twrp.me/zuk/zukz2.html
4- WIPE System, Data, Cache
5- Copy rom file to internal storage
6- Try to flash again
7- Profit.

Good luck! :)