Bringing back default SMS to Messaging app

Oct 20, 2016
39
2
8
#1
Hi,
Zui ver 3.1.117 on Zuk Z2 (2131).
I have installed Truecaller and had it as the default SMS app.
Now as I'm not quite happy with it as the SMS app I want to assign the factory app Messaging to be the default app for SMS again, but I failed to do that no matter what I tried:
Trough Settings -> Advanced Settings -> Applications
I opened Truecaller and hit Clear Defaults.
Then the Facebook Messenger took over the SMS defaults, so I cleared it as well but it keeps to be the default app.
When I open Messaging I get the popup "Messaging is not your SMS app."
Messaging does not appear under the advance settings application list.

How can I make Messaging the default SMS app again?
 
Oct 20, 2016
39
2
8
#2
Found it. After searching more I found that the answer is pretty simple:
Settings -> Advanced Settings -> Applications, scroll to the bottom of the application list you have Preferred Apps -> in there you can set the default apps for system actions: Launcher, Phone, Messaging, Browser, Camera, Gallery, Music, Email, Video
 
Likes: niiaryee