Do you want to update to Oreo? READ THIS FIRST!

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#81
Yes of course, i'll install all stuffs starting from last 3 5.***. I'll do that to have clean flash since last release and not old installation with ota. More clean possible.

Inviato dal mio Z2 Pro utilizzando Tapatalk
A clean flash is flashing 1.9

Read this and you will understand.

I would not have put all this process in the tutorial if it was not important to flash 1.9

Sure there are cases that just updating works fine, but there are a lot of people here claiming that something isnt working on Oreo, that it isnt stable so this tutorial is for those people
 

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#82
Hello bruneba,

First of all thank you for this great tutorial. I followed all the steps untill "fastboot boot recovery.img" Like others I get the message "waiting for device". I installed adb and fastboot. No result. What can be the problem?
At first my Zuk Z2 Pro was unlocked, TWRP installed and I flashed some custom roms to try out. But I like the ZUI more than others, so I read this tutorial and did step by step.

I really want to finish this upgrade to Android 8, so can you help me please?
Or any other person who knows what I must do.

Thank you, Alex

update: I installed TWRP before, so at that time windows commands worked. Why not now?
 
Likes: bruneba

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#83
Hello bruneba,

First of all thank you for this great tutorial. I followed all the steps untill "fastboot boot recovery.img" Like others I get the message "waiting for device". I installed adb and fastboot. No result. What can be the problem?
At first my Zuk Z2 Pro was unlocked, TWRP installed and I flashed some custom roms to try out. But I like the ZUI more than others, so I read this tutorial and did step by step.

I really want to finish this upgrade to Android 8, so can you help me please?
Or any other person who knows what I must do.

Thank you, Alex
Did you enable usb debugging? After enabling it, it will show a screen on your phone when you connect the cable to pc, accept it.

Then type in adb: adb devices
Press enter

it will see your device, now you can keep following the tutorial
 

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#84
Did you enable usb debugging? After enabling it, it will show a screen on your phone when you connect the cable to pc, accept it.

Then type in adb: adb devices
Press enter

it will see your device, now you can keep following the tutorial
Yes, I did. My device was recognized and went in fastboot mode after : adb reboot bootloader". But next step: no
 

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#86
Yes, I did. My device was recognized and went in fastboot mode after : adb reboot bootloader". But next step: no
If your phone was restored, you must enable it again. Just check to see if it is really enabled.

If not, after that.

Turn your phone on, plug the cable, open adb and type: adb kill-server
press enter

adb start-server
Press enter

Now see if a screen will pop in your screen to accept it
 
Likes: QCLasky

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#87
I also tried to install update.zip with updater app, but error: update failed.
Did you rename it propearly? The zip file must be "update" .zip is the file extension.

Some people rename it wrong and ends in update.zip.zip :p

And make sure to put the file in /phone
Not inside any folder
 
Likes: QCLasky

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#88
Did you rename it propearly? The zip file must be "update" .zip is the file extension.

Some people rename it wrong and ends in update.zip.zip :p

And make sure to put the file in /phone
Not inside any folder
Yep, I named it update.zip

I will execute what you wrote in the post before, will let you know in a bit

And I put the update.zip in internal storage of the phone, not in a folder
 

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#89
If your phone was restored, you must enable it again. Just check to see if it is really enabled.

If not, after that.

Turn your phone on, plug the cable, open adb and type: adb kill-server
press enter

adb start-server
Press enter

Now see if a screen will pop in your screen to accept it
After these commands not a popup
 

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#92
yep, but i just see that i downloaded the wrong rom, i took from 3.1 to 3.5, but i must have the other one. Can i install that one with the updater app? I am sorry for this (stupid) mistake...have to download first
If you dont have bootloader unlocked ypu can update with system recovery.
Are you on zui 3.1? Download the OTA in the tutorial and update manually with system recovery (if you dont have bootloader unlocked)
 
Likes: QCLasky

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#93
If you dont have bootloader unlocked ypu can update with system recovery.
Are you on zui 3.1? Download the OTA in the tutorial and update manually with system recovery (if you dont have bootloader unlocked)
Phone was unlocked. I first flashed 1.9 (and phone was locked again right?), then I flashed 3.1 (both with QFIL). All went well.
Just downloaded the 3.5 rom and renamed it to update.zip and put it in internal storage. Failed again with system recovery.
 

Alexzui

Active Member
Jul 30, 2016
285
29
28
Rotterdam, Netherlands
#94
If you dont have bootloader unlocked ypu can update with system recovery.
Are you on zui 3.1? Download the OTA in the tutorial and update manually with system recovery (if you dont have bootloader unlocked)
did the adb devices again and i get this: serialnumber + device. Does this mean phone is unlocked? Otherwise there was "Unauthorised" right?
 

bruneba

Well-Known Member
Apr 8, 2017
1,811
1,060
113
#95
Phone was unlocked. I first flashed 1.9 (and phone was locked again right?), then I flashed 3.1 (both with QFIL). All went well.
Just downloaded the 3.5 rom and renamed it to update.zip and put it in internal storage. Failed again with system recovery.
Idk why it isnt working for you... What happens when you just rename it to update, without .zip?