Do you want to update to Oreo? READ THIS FIRST!

bruneba

Well-Known Member
Apr 8, 2017
1,749
1,037
113
Now BL is open and phone is rooted... :-/

Is it now possible, too?

=> unroot + stock recovery => OTA flash to 3.5.316 => TWRP + Magisk?

Or will all be deleted and the "new" apps (dialer, etc.) gone?

(I'd better do a full backup before ;-) )
If you have TWRP now then do a backup before trying anything
What is your zui version right now? If you are on 3.1 you can try to install the full 3.5 OTA with TWRP.
If anything goes wrong then use your backup to restore your data or try as described on tutorial.
 
Likes: Hellge77
Aug 26, 2016
145
19
18
Erding, Germany
If you have TWRP now then do a backup before trying anything
What is your zui version right now? If you are on 3.1 you can try to install the full 3.5 OTA with TWRP.
If anything goes wrong then use your backup to restore your data or try as described on tutorial.
Now I'm on 3.5.259 with BL unlocked & root (TWRP & Magisk).

Where can I find the 3.1 to 3.5 OTA TWRP method?

My way until now:
- 1.9 QFIL
- 3.1 QFIL
- steps according post #1
- OTA update to 3.5.259 via update.zip & stock recovery
- failed OTA updates to 3.5.316 via update.zip & stock recovery (=> solution probably "update" without zip-ending)
- TWRP + Magisk
 

bruneba

Well-Known Member
Apr 8, 2017
1,749
1,037
113
Now I'm on 3.5.259 with BL unlocked & root (TWRP & Magisk).

Where can I find the 3.1 to 3.5 OTA TWRP method?

My way until now:
- 1.9 QFIL
- 3.1 QFIL
- steps according post #1
- OTA update to 3.5.259 via update.zip & stock recovery
- failed OTA updates to 3.5.316 via update.zip & stock recovery (=> solution probably "update" without zip-ending)
- TWRP + Magisk
The full ota file is already on tutorial.

Try without .zip some devices hide the name extension so you ends with a file update.zip.zip :p
 
Likes: QCLasky

Alexzui

Active Member
Jul 30, 2016
274
38
28
Rotterdam, Netherlands
Now I'm on 3.5.259 with BL unlocked & root (TWRP & Magisk).

Where can I find the 3.1 to 3.5 OTA TWRP method?

My way until now:
- 1.9 QFIL
- 3.1 QFIL
- steps according post #1
- OTA update to 3.5.259 via update.zip & stock recovery
- failed OTA updates to 3.5.316 via update.zip & stock recovery (=> solution probably "update" without zip-ending)
- TWRP + Magisk
Look in the first post like bruneba said. It's there. Name it update. Update with stock recovery (don't install twrp yet, so stock recovery is in the phone already with the 3.1 rom). That's what I did and now everything is good.
 

Sandro_

New Member
Mar 27, 2018
6
0
1
Great tutorial thanks!
Unfortunately my google contact sync doesn't work. I've whitelisted everything and set the simple dialer as default.
But the sync haven't worked before :(
Any suggestions?
 

bruneba

Well-Known Member
Apr 8, 2017
1,749
1,037
113
Great tutorial thanks!
Unfortunately my google contact sync doesn't work. I've whitelisted everything and set the simple dialer as default.
But the sync haven't worked before :(
Any suggestions?
Did you add the google sync app to white list too? Add it to autostart white list, dont tick it.
Screenshot_2018-03-27-18-21-34-1343643220.png
Screenshot_2018-03-27-18-22-42-1688143885.png
 
Likes: QCLasky

nksonfire

New Member
Mar 28, 2018
2
4
3
Yes I've whitelisted everything in the safecenter

It didn't worked for me, what worked is:
1. Goto contacts.google.com
2. Click top left, select more > Export (it'll ask you to go to older version, do that)
3. Again select 'more' > Export and download contacts.vcf
Done.
 

Sandro_

New Member
Mar 27, 2018
6
0
1
It didn't worked for me, what worked is:
1. Goto contacts.google.com
2. Click top left, select more > Export (it'll ask you to go to older version, do that)
3. Again select 'more' > Export and download contacts.vcf
Done.
Yep but that doesn't solve the sync issue right? I just download the contacts once?
 

Alexzui

Active Member
Jul 30, 2016
274
38
28
Rotterdam, Netherlands
Something is wrong with your rom. Try to follow the tutorial again. Safe Center has to be named Security on 3.5.316
Hello, sorry to ask you here in this post, but is there also such a great tutorial for upgrading the Zuk Z2 to Android 8 with QFIL?
I have a Z2 too and it's on ZUI 2.5.106 ST with stock recovery. Have to find out if it's unlocked.
 

bruneba

Well-Known Member
Apr 8, 2017
1,749
1,037
113
Hello, sorry to ask you here in this post, but is there also such a great tutorial for upgrading the Zuk Z2 to Android 8 with QFIL?
I have a Z2 too and it's on ZUI 2.5.106 ST with stock recovery. Have to find out if it's unlocked.
There isn't any 3.5 qfil file yet, so you have to update it by OTA or manually just like in this tutorial.
 
Likes: QCLasky
Sep 20, 2016
147
14
18
44
I tried to update as described, but my phone never wanted to go to edl mode (I was on 3.1.218, bootloader unlocked and rooted and are worked right), so I could not flash 1.9, etc. Finally I made a factory reset (lost root) and updated with the renamed OTA from the stock recovery. Update worked and everything is OK. Now I am on 3.5.316 and happy, but without root this time.

Sent from my ZUK Z2121 using Tapatalk
 
Feb 19, 2018
38
5
8
hi, i forgot to install contacts and dialer on 3.1 and now im on 3.5, can i do it anyways?
 
Last edited: