Do you want to update to Oreo? READ THIS FIRST!

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
I tried to update as described, but my phone never wanted to go to edl mode (I was on 3.1.218, bootloader unlocked and rooted and are worked right), so I could not flash 1.9, etc. Finally I made a factory reset (lost root) and updated with the renamed OTA from the stock recovery. Update worked and everything is OK. Now I am on 3.5.316 and happy, but without root this time.

Sent from my ZUK Z2121 using Tapatalk
You can easily unlock bootloader on 3.5.

if you aren't already, unlock it and flash magisk with TWRP to root
 
Likes: QCLasky

n0body

New Member
Mar 17, 2018
7
1
3
I worked all the steps as described, everything seems to work fine, except one thing: the google play app (v8.7.50) cannot update (clicking on version under settings does initiate a download on the notifications but when it is finished it disappears, it doesn't install). Any idea anyone?
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
I worked all the steps as described, everything seems to work fine, except one thing: the google play app (v8.7.50) cannot update (clicking on version under settings does initiate a download on the notifications but when it is finished it disappears, it doesn't install). Any idea anyone?
Hm.. Idk, try to clear its cache and data

Do you have bootloader unlocked?
Maybe it didn't pass safetynet.
 

n0body

New Member
Mar 17, 2018
7
1
3
Thanks for you reply :)
I have tried clearing cache/data - uninstalling and reinstalling via app centre.

Indeed my bootloader is unlocked and magisk installed, where the SafetyNet result is:
ctsProfile: false
basicintegrity:true

I have no idea what the first one is but since all my root requiring apps work I didn't pay too much attention.
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
Thanks for you reply :)
I have tried clearing cache/data - uninstalling and reinstalling via app centre.

Indeed my bootloader is unlocked and magisk installed, where the SafetyNet result is:
ctsProfile: false
basicintegrity:true

I have no idea what the first one but since all my root requiring apps work I didn't pay too much attention.
You just have to install and enable a module to pass safetynet.
But remember to disable xposed framework if you have it enabled, or it will never pass.

https://forum.xda-developers.com/showpost.php?p=73432221&postcount=1075

After you get both results as true, clear play store data and cache
 

n0body

New Member
Mar 17, 2018
7
1
3
Thanks, I tried it, now both SafetyNet tests are true but still same thing. I noticed now that under version. Device Certification field is now Certified (before isntalling the SafetyNet module it was uncertified).

Which is the latest Google Play version for 3.5.316? I could try installing via apk.
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
Thanks, I tried it, now both SafetyNet tests are true but still same thing. I noticed now that under version. Device Certification field is now Certified (before isntalling the SafetyNet module it was uncertified).

Which is the latest Google Play version for 3.5.316? I could try installing via apk.
Idk what is the latest, I'm on a custom ROM now.
Why you want to update it? It isn't working fine as it is?
 

n0body

New Member
Mar 17, 2018
7
1
3
I am just afraid it might be other issues in the future related to google services (e.g. contacts sync). It does work fine though, so I will stick to it for now.
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
I am just afraid it might be other issues in the future related to google services (e.g. contacts sync). It does work fine though, so I will stick to it for now.
since I installed the playstore with app center on stock rom, I never had any issue with this app, so dont worry
 
Sep 20, 2016
144
14
18
44
You can easily unlock bootloader on 3.5.

if you aren't already, unlock it and flash magisk with TWRP to root
My bootloader remained unlocked after the update as I did it over the 3.1.218 and not from 1.9. But anyhow fastboot mode does not want to working right (just like the edl mode). ADB list my device and I can boot to bootloader, but from here I cannot flash (or boot to) TWRP...

Sent from my ZUK Z2121 using Tapatalk
 
Sep 20, 2016
144
14
18
44
Thanks, I tried it, now both SafetyNet tests are true but still same thing. I noticed now that under version. Device Certification field is now Certified (before isntalling the SafetyNet module it was uncertified).

Which is the latest Google Play version for 3.5.316? I could try installing via apk.
Just search for it on apkmirror


Sent from my ZUK Z2121 using Tapatalk
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
Actually I don't recommend installing other version if yours is working fine.. I remember the time I did that and I got too many crashes on play store..
But it is your phone, so you can try if you want :p
 

bruneba

Well-Known Member
Apr 8, 2017
1,720
1,028
113
My bootloader remained unlocked after the update as I did it over the 3.1.218 and not from 1.9. But anyhow fastboot mode does not want to working right (just like the edl mode). ADB list my device and I can boot to bootloader, but from here I cannot flash (or boot to) TWRP...

Sent from my ZUK Z2121 using Tapatalk
So, that's a good reason to lock it again flashing 1.9. It should fix this issue.

Force edl mode using button combination.

Turn off your phone.
Press and hold Volume Up and Volume Down button
Connect your phone to the computer with a type-c usb cable
Your Phone is now in fastboot mode (release the keys)
Open terminal (cmd) and type
fastboot -i 0x2b4c oem reboot-edl
 
Likes: QCLasky
Sep 20, 2016
144
14
18
44
So, that's a good reason to lock it again flashing 1.9. It should fix this issue.

Force edl mode using button combination.

Turn off your phone.
Press and hold Volume Up and Volume Down button
Connect your phone to the computer with a type-c usb cable
Your Phone is now in fastboot mode (release the keys)
Open terminal (cmd) and type
fastboot -i 0x2b4c oem reboot-edl
Thx for the hint, maybe sometime I will try it, but now I am happy with the phone as it is

Sent from my ZUK Z2121 using Tapatalk
 

Avan

New Member
Mar 14, 2017
14
2
3
Thanks for the helpful guide. Just wished the host was not MEGA, I'm at 37% downloading zukpro19 and I already exceeded my bandwidth.