[Gelöst] Kann keine APK's installieren. Paket-Installer wurde beendet.

renge

New Member
May 30, 2017
12
1
3
#1
Edit: Lösung:
zukfans.eu/community/threads/geloest-kann-keine-apks-installieren-paket-installer-wurde-beendet.6209/#post-48854
- - - - -
Ich brauche hilfe!

Folgendes habe ich installiert:
Dirty Unicorn ([7.1.x][Z2] Unofficial Dirty Unicorns by davidevinavil) -> GApps (pico) -> Magisk.
"Apps von unbekannten Quellen zulassen" ist an.

Wenn ich auf eine apk klicke dann wird der Paket-Installer beendet.
Ich bekomme nicht einmal die "Abbrechen / installieren" Abfrage.
Video: s1.webmshare.com/EBKmY.webm

Darauf hin habe ich GApps nano installiert und danach Beans GApps. Leider keine Lösung.

Was kann ich versuchen um dieses Problem zu lösen?
 
Last edited:
Mar 19, 2017
50
20
8
#4
klingt nach unsauberer installation.
Überhaupt richtig stable ist mir bislang nur bekannt, wenn man mit qfil 1.9 drauf macht und dann via ota bis auf 2.5.335 hochgeht und dann erst das macht was man machen möchte (twrp, custom rom usw.).
Erzähl mal deine geschichte von anfang an, was du so gemacht hast bis du auf dirty unicorn gekommen bist.
 

renge

New Member
May 30, 2017
12
1
3
#5
Ich hatte mal einen Brick (schwarzer Bildschirm, weißes Licht. Kein Start.)
konnte aber Unbricken und habe dann folgendes Geflasht
Z2131_CN_OPEN_USER_Q01080.2_N_ZUI_2.5.334_ST_170116_qpst

Danach Unlock gemacht, TWRP und Mokee 6.0 draufgeflasht.
Lief alles gut.

Dann DU Geflasht:
Bin nach Anleitung gegangen:
  1. Wipe Data, Cache and Dalvik Cache gemacht
  2. DU zip geflasht, danach GAPPS und Magisk
  3. Neustart
  4. Fertig
Jetzt noch ausprobiert:
Nochmal Werk Reset in TWRP gemacht (Wipe Data, Cache and Dalvik Cache)
Dann BeansApps Geflasht + Cache and Dalvik Cache clear gemacht
Neugestartet -> Direkt versucht eine APK zu installieren, selber Fehler.
>Paket-Installer wurde beendet.

P.S.: Habe ältere Baseband Version 1.70664.3.76387.1. Hat das eventuell einen Einfluss?
 
Mar 19, 2017
50
20
8
#6
ich persönlich habe die erfahrung gemacht, dass es schon damit losgeht weil man direkt in eine höhrere version geflasht hat.
ich weiß nicht woher das problem herrührt, aber ich denke das die höhren versionen irgendwie nicht alle nötigen informationen beisamen haben.
kannst im forum schauen , gibt viele leute hier die random bugs haben, die kontinuierlich wieder auftreten.
sei es mic problem, camera problem, system crashes, dein problem.

ich hab anfangs ähnlich wie du direkt auf eine höhere version via qfil geflasht und es dabei belassen. bei mir war es 2.3 st.
also nichts habe ich verändert alles war stock, clean.
ich hatte probleme mit der camera, telefonabbrüche, verbindungsprobleme etc. pp.

daher ist die stabilste methode erst mal qfil mit 1.9 und dann erst mal mit ota bis auf latest 2.5.335
die letzte version der zui basiert ja auf android 7, welches dann mit einer custom rom, die anschließend drauf geflasht wird, gut harmoniert.

naja weimerd kennt sich in dem bereich sehr gut aus, vielleicht hat er noch den ein oder anderen tip.
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,362
1,121
113
#7
grundsätzlich kann ich da nur zustimmen.
Mach einen flash mit qfil nach 1.9
Dann per OTA nach 2.5
Dann Bootloader unlocken
twrp installieren
daten, cache und dalvik löschen
CustomRom auf Android7 basierend installieren.
ggfs. dann noch nano gapps von opengapps.org installieren.
ggfs dann noch aktuelle supersu zip installieren, je nach customrom

Beim Z2 kann ich dir kein Rom empfehlen, habe selbst das Z2 Pro und nutze AICP
 

renge

New Member
May 30, 2017
12
1
3
#8
Hallo,

danke für die Antwort.
Ich habe mein Problem lösen können.

DU installieren -> neustart.
Beans / GApps installieren -> neustart.
etc.

Nach dem ich DU installiert hatte und einen Neustart gemacht habe, konnte ich APK's installieren.
Zuvor habe ich zu Testzwecken alles neu installiert (ohne neustart) und gleicher Fehler.
Sicherheitshalber habe ich jeweils nach einer Installation einmal neugestartet.

Falls andere Probleme/Bus auftreten sollten, werde ich wohl die qfil Methode versuchen.
 

rolex0815

Active Member
Jul 18, 2016
300
85
28
#9
Es ist völlig irrelevant, welche Version eine Custom ROM hat von der Android Version her bzw. welche ZUI Version drauf ist/war.
Das eine hat mit dem anderen nichts zu tun und wird bei einem Flash komplett überschrieben bzw. ersetzt. Da muss auch nichts "harmonieren", es ist unerheblich, was da vorher drauf war.

Anders sieht es beim Baseband bzw. den Firmware Files aus, die können inkompatibel sein, sind es aber in den überwiegenden Fällen nicht.

Der TE hat möglicherweise nicht richtig geflasht (Reihenfolge nicht eingehalten z.B.) , eine falsche TWRP Version benutzt oder ein korruptes Image File des Custom ROMs.

Auch der Tipp zuerst mit QFIL auf 1.9 und dann per OTA hoch ist völlig nutzlos, außer Zeit und Nerven bringt es nichts.

Das hier nur zur Klarstellung, damit sich andere evtl. was ersparen.
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,362
1,121
113
#10
@rolex0815 Das ist schlicht falsch.

Beim Flashen einer CustomRom werden eben NICHT alle Partitionen überschrieben, sondern i.d.R. nur das System.
Beim ZUK Z2 (Pro) besteht ein lauffähiges System aber aus deutlich mehr Partitionen als nur System, Data, Cache und Dalvik.
Genau DA liegt der Hund begraben.

Warum schafft es nur die 1.9er Version, auch den Bootloader wieder in unlocked-Status zu bringen?

Warum laufen CustomRoms auf Android7 schrottig oder gar nicht, wenn du die über eine ZUI 2.3 abwärts installierst?

Warum laufen CustomRoms auf Android6 schrottig oder gar nicht, wenn du die über eine ZUI 2.5 installierst?

Die Variante, die ich beschrieben habe entspringt aus ausreichend Erfahrung, Systeme wieder flott zu machen und vor allem stabile Installationen zu ermöglichen.

Natürlich kann man auch frickeln. Geht manchmal auch. Daraus will ich aber kein Tutorial machen, ist einfach zu fehleranfällig und die meisten User suchen ja hier nach Lösungen, um vernünftig laufende Roms zu bekommen.

In diesem Sinne: Möge jeder seine Erfahrungen machen ;)
 

rolex0815

Active Member
Jul 18, 2016
300
85
28
#11
Du hast nicht genau gelesen, geht es um die Firmware Files (die nur mit QFIL geflasht werden können bei ZUK Smartphones) ist das korrekt.

Ein aktuelles Custom ROM basierend auf AOSP besteht aus den folgenden Partitionen:
  • System
  • Data
  • Cache
  • Recovery
  • Boot
und die werden beim Flash einer Custom ROM überschrieben (je nach gesetzten Recovery Häkchen).

Deine anderen Beispiele sind nichts, wo ich vorher widersprochen habe, liegt aber an den Firmware Partitionen, die in der Liste NICHT aufscheinen.
Es geht überhaupt nicht um den Bootloader, wo kommt der auf einmal her? o_O

Und wenn der TE ein Problem hat, keine apks installieren zu können, hat das mit der Firmware und Baseband überhaupt nichts zu tun, da hakt es rein bei der Softwareumgebung.
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,362
1,121
113
#12
Der TE hatte eine spannende Vorgeschichte. Ich habe mir abgewöhnt, an Problemen in zusammengefrickelten Roms zu arbeiten.
Sicherlich hast du damit Recht, dass nicht alle Probleme auf eine unsaubere Installation zurückzuführen sind.

ABER: Für mich isf eine grundsätzlich saubere Installation Voraussetzung, um weitere Hilfestellungen zu geben. Für alles Andere ist mir meine Zeit zu schade, denn man arbeitet sich so oft leider an Problemsymptomen ab, die mit einer sauberen Grundinstallation einfach nicht vorhanden sind.

Also nichts gegen deine Einstellung, ich finde es gut, dass du dir mit Gedanken machst :)
Das Problem ist ja mittlerweile gelöst, also alles gut :)
 
Likes: rolex0815