[HOWTO] Flash a Stock ZUI ROM (ZUK Z2 Z2131 only!)

Status
Not open for further replies.
May 24, 2017
39
2
8
i cant post links yet crisps, because i have less than 10 posts. method one FINALLY worked for me but i get this error inside QFIL:

"Download Fail: Sahara Fail: QSahara Server Fail: Process Fail"

i changed usb ports, reboot my pc and phone and that happened.
 

crisps

Well-Known Member
Aug 28, 2016
1,109
473
83
Method one???

Sahara fail did you try the solution in the tutorial?

Gesendet von meinem Z2 Pro mit Tapatalk
 
May 24, 2017
39
2
8
Method one???

Sahara fail did you try the solution in the tutorial?

Gesendet von meinem Z2 Pro mit Tapatalk
it finally worked! i created a folder in C: called just "zuk" and the folder with the rom was like "1". this time worked. looks like QFIL cant deal with long paths. but now my phone is in english. theres a way to download brazilian language? i also trying to figure out how to install gapps on the phone. the phone is
partially in chinese. i cant find anything like a folder manager yet to select the apks.
edit: maybe i will install lineage os, those default chinese apps are shit. those bloatware make me paranoid, i wonder if theres chinese spying my data, and stuff. I use applications from my brokerage and bank on the phone. I do not feel safe using a phone full of bloatware.
 
Last edited:

RJCS

New Member
Jun 3, 2017
1
0
1
Hey guys. I am confused in what ROM version should I apply. The latest one had CN in it, would like to avoid chinese. What do you recomend I do?
 
Jun 5, 2017
1
0
1
I just installed ZUI 2.3, but sadly, I can't the the GAPPS to work, tried several methods.

The Google Play is stuck on the loading screen. Is there any way to fix this, or should I flash the 1.9 ZUI and install the GAPPS, and thenupdate with OTA?

Hope someone can help
 

Mattemaio

New Member
Nov 29, 2016
24
4
3
25
upload_2017-6-5_16-58-19.png

Now, my phone is bricked.
It's vibrate every 25/30 second, and led blink. (Without i touch it)
And i don't know how stop/turn off it. If i press power button for about 10 second it vibrates again. But after 30 second, restar.
Someone can help me?
 
Last edited:

Mattemaio

New Member
Nov 29, 2016
24
4
3
25
Hello,
Can you please help?
I got my phone bricked, installed QFIL and switched to mode 9008 and when I press download I get

Download Fail:FireHose Fail:FireHose Fail:FHLoader Fail:process fail
Finish Download



Below all the log

18:46:13: INFO: Current working dir (cwd): C:\Users\pnikolaidis\AppData\Roaming\Qualcomm\QFIL\COMPORT_8\
18:46:13: INFO: Showing network mappings to allow debugging
18:46:13: INFO: User wants to talk to port '\\.\COM8'
18:46:13: INFO: Took 0.00000000 seconds to open port
18:46:13: INFO: Sorting TAGS to ensure order is <configure>,<erase>, others, <patch>,<power>
18:46:13: INFO: If you don't want this, use --dontsorttags
18:46:13: INFO: Sending <configure>
_____
| ___|
| |__ _ __ _ __ ___ _ __
| __| '__| '__/ _ \| '__|
| |__| | | | | (_) | |
\____/_| |_| \___/|_|
18:46:13: {ERROR: XML not formed correctly. Expected a &lt; character at loc 0}
_____
| ___|
| |__ _ __ _ __ ___ _ __
| __| '__| '__/ _ \| '__|
| |__| | | | | (_) | |
\____/_| |_| \___/|_|
18:46:13: {ERROR: 3. TAG not found or recognized}
_____
| ___|
| |__ _ __ _ __ ___ _ __
| __| '__| '__/ _ \| '__|
| |__| | | | | (_) | |
\____/_| |_| \___/|_|
18:46:13: {ERROR:
There is a chance your target is in SAHARA mode!!
There is a chance your target is in SAHARA mode!!
There is a chance your target is in SAHARA mode!!
This can mean
1. You forgot to send DeviceProgrammer first (i.e. QSaharaServer.exe -s 13:prog_emmc_firehose_8994_lite.mbn)
2. OR, you did send DeviceProgrammer, but it has crashed and/or is not correct for this target
Regardless this program speaks FIREHOSE protocol and your target is speaking SAHARA protcol, so this will not work
}
Download Fail:FireHose Fail:FireHose Fail:FHLoader Fail:process fail
Finish Download
Same problem
 

sahartje

New Member
Jun 5, 2017
25
3
3
25
This took me 15 minutes. Thank you very much! 1st time it Didn't work, I renamed the folder to ZUK and it did work then :)!
Just a problem, how do I change the language if that's even possible, to English? I can''t read Chinese whoops...
 
Mar 15, 2017
4
0
1
Hey, I´ve been having some problems with my zuk z2 and it seemed that the only solution was to flash into a stock ROM. So I followed all the steps on this tutorial and when I installed the fastboot program and inserted the command "adb reboot edl" my phone just died, and now it´s not responding to anything, it doesn´t turn on and the computer doesn´t recognise it either
 

rolex0815

Active Member
Jul 18, 2016
302
85
28
It's most likely not dead, but in EDL mode as requested.

If QFIL and drivers are properly installed + phone connected to the PC, QFIL should recognise the phone.
 
Mar 15, 2017
4
0
1
yeah, the program recognises the phone, and after i press the download buttom all the icons stay grayed for a while and after some time the program says: Download fail: Sahara fail: QSaharaServer Fail: Process Fail and nothing else happens
 

ramees.kr

New Member
May 8, 2017
27
2
3
24
yeah, the program recognises the phone, and after i press the download buttom all the icons stay grayed for a while and after some time the program says: Download fail: Sahara fail: QSaharaServer Fail: Process Fail and nothing else happens
Use mi flash tool.
It doesn't have any problem.

Earlier i used to used qfil but it always showed Sahara error.

I've not got any error using mi flash tool

Sent from my ZUK Z2131 using Tapatalk
 

crisps

Well-Known Member
Aug 28, 2016
1,109
473
83
Stop this MiFlash suggestion.
Did you all read the tutorial carefully??

MiFlash cant flash all partition.
If you get later wny problems, dont cry here abou it

Gesendet von meinem Z2 Pro mit Tapatalk
 

royk5050

New Member
Apr 20, 2017
10
0
1
Thanks alot worked like a charm, 15 min or so.
Flashed 2.5.412 straight up.

Maybe worth noting for new comers (like me) that the "download" state is nothing but black screen and rebooting after ROM is applied takes few minutes.

Also my phone had a more up to date version pre installed - zuk driver 1.08, so i didn't downgraded it.

Thanks again !
 
Status
Not open for further replies.