Last try for help before getting a new phone...

Mar 29, 2017
40
2
8
#1
Hi,

I wrote as well in the main Z2 Pro Forum, but maybe this is the right place because I got no answers there.

I had my Z2 Pro running on Stock. I had some issues I could not solve no matter how many options I tried, like the phone not charging when it was off (it did normally if it was on), or whatsapp going to sleep so I needed to start it to get new messages every 10 minutes.

So I thought I would try a custom rom to see if it runs better so and here is were the nightmare starts.

First I unlocked the phone and installed TWRP and then AOSP Extended and Gapps.

All seemed fine, but I realized the phone was not charging. When I plugged it in, it shortly showed it was charging and then no more.

Also my PC would not recognized the phone so I cannot tranfers files.

I tried Arrow and RR, same behaviour, except for RR, it seemed to charge a bit but extremely slowly.

Next step, changed from TWRP to Redwolf. With this change at least the phone was recognized in recovery mode so I could transfer files but not in system.

With Redwolf and RR without Gapps I manage to charge the phone so I could keep it alive all this hours but with the weirdest behaviour. Charging varies from 4000 mA to as low as 15 mA without temperature variation on the phone that might explain it. For example now the phone was at 6%. I plugged it after wiping everything once again with RedWolf and installing RR again (no Gapps). I started, plugged in, charging at almost 4000mA up to 9%, after that it dropped and now it is charging at 15mA. Sometimes goes up to 600mA then down again. Tempearute is stable under 30°.

It seems to me it is a software topic and not a hardware one but I cannot find any solution no matter how much I search and I am desperate.

I will keep trying today and if it doesnt work I think I am going to give up and get a new phone. The ZUK has a great hardware but I dont know why I always had software issues with it.

Maybe someone can help me and has some further ideas. What I am trying next is older versions os AOSP, RR etc. and older TWRP versions.

Thanks for your help
 
Mar 29, 2017
40
2
8
#2
Now I switched to TWRP 3.2.1 with RR 7.1. The bad news is that the behaviour in the system is the same. The good news is that I managed to charge the phone in the recovery mode, up to now around 50% in one hour which is quite ok. Also I can access the phone files from recovery mode.

But of course it is not really great to have to switch to revocerys mode to charge the phone....

I am downloading Mokee 9 and RR 6.2 to try, we will see...
 
Mar 29, 2017
40
2
8
#3
Ok, it looks like I found a solution. It does not seem like anybody has the same problem like I had here, but maybe it will help anyone in the future...

So I stayed at TWRP 3.2.1 because it seemed to be fine.

After that I tried a few ROMS.

None of the ROMs based on Android 9 worked for me (they did not charge and could not connect to PC)

Some of the Android 8.1 ROMS gave me an error 7 while installing them (for example RR 6, Lineage 15.1 and Mokee 8.1)

Finally I got 2 ROMS that, on the first sight, seem to work for me: CosmicOS based on Android 8.1 and Lineage 14.1 based on Android 7.1

I stilled did not install Gapps, hope I dont get trouble with that, but apparently with these 3 I can charge the phone and connect it to the PC.

I am going with Cosmic for the moment and hope not to get more trouble....

Hope this helps anyobody. Still I will be happy if someone has an idea why I am getting this issues.
 
Last edited:
Mar 29, 2017
40
2
8
#4
After using it for some hours, I detected yet again a weird effect: charging is only possible over a computer. If I connect the phone (with the same cable) to the charger, it shows the charging symbol but does not charge. I tried with two different cables and two different cables. But I think I can live with that for while...
 

nero355

Active Member
Jan 14, 2017
529
149
43
#5
Mate... isn't your battery simply fucked and causing all these issues ?! :(

The only other thing I can think of is the connector but my guess is it's the battery!