ROM [OFFICIAL][8.1.x] DiscoveryROM [OMS][High-Performance!]

DiscoveryTeam

Administrator
Staff member
Apr 6, 2017
56
98
18
#1
Features:
• OTA
• Pixel style
• Home button to turn on screen
• Navbar enabler
• Three-finger screenshot
• LED customization
• Double tap to sleep and double tap to wake
• Quick Pulldown
• Ambient display


And more features will come with time...

Please give feedback:
OTG

Bugs
VoLTE
Preinstalled clock - USE GOOGLE CLOCK from Playstore
LED (solved in next release)

Let us know


Changelog:
Dicovery ROM Official post on Telegram Channel


Download Link:
Downloads: Discovery Official site (please no mirror!)

!!! VERY IMPORTANT!!!
• It's better to do a clean install
• Update baseband to 1.7 (zui 2.5) otherwise turning on wifi will end in kernel panic
• Use 8.1 opengapps that you can find here: opengapps_xda
• If you want to use GoogleCam, best working apk is here: GoogleCamera-PixelMod-Arnova8G2-5.1.018




Sources: Discovery Github

Website: https://www.discoveryrom.org
Donations: Support us

Follow Us on:

Google+: Discovery ROM Official Google+ page
Facebook: Discovery ROM Official Facebook page
Join our community: Discovery ROM community
Telegram channel: Discovery ROM channel


ROM OS Version: 8.1.x Oreo
Based On: AOSP, CAF

Version Information
Status:
Stable
Current Stable Version: RC1, D1
Stable Release Date: 2018-01-13

Created 2018-01-17
Last Updated 2018-01-17
 
Last edited:

BeNeDeV

New Member
Mar 11, 2017
13
3
3
#9
After installing it, it starts as usual with the zuk logo, but as soon as it disappears I get a black screen (screen is on but black) and the phone heats up... What am I doing wrong?
 

cesare

New Member
Jan 16, 2017
17
3
3
45
#10
After installing it, it starts as usual with the zuk logo, but as soon as it disappears I get a black screen (screen is on but black) and the phone heats up... What am I doing wrong?
Update baseband maybe

Inviato dal mio Z2 Plus utilizzando Tapatalk
 

Mixxer5

Active Member
Nov 12, 2016
115
47
28
25
#12
I've been testing it for a while (short one, about an hour) and it looks pretty solid. I get weird "UI crash" when I restart phone and textra quick compose notification is small by default (needs extra click to open) and there seems to be bug when waking device (screen is black- needs to be put to sleep and waken again). Overall- quite solid, I'm waiting for updates!
 

Mot Atlas

New Member
May 7, 2017
7
0
1
#13
What do you mean by kernel panic? I updated from the ota download, and it worked fine a while, then i rebooted and had the same problem as BeNeDeV
 

Mot Atlas

New Member
May 7, 2017
7
0
1
#14
What do you mean by kernel panic? I updated from the ota download, and it worked fine a while, then i rebooted and had the same problem as BeNeDeV
I reinstalled it, and now as I activate wifi, the device's screen turns black, and the led turns white. How can I solve this?
 

DiscoveryTeam

Administrator
Staff member
Apr 6, 2017
56
98
18
#15
@Mot Atlas this is a baseband problem.. it's written in the first post.
@Mixxer5 did you clean flashed (all wipes except persist)? In case you still have problems with unlock try to disable ambient display always on (but keep active ambient on notification)
 

Mot Atlas

New Member
May 7, 2017
7
0
1
#17
@Mot Atlas this is a baseband problem.. it's written in the first post.
@Mixxer5 did you clean flashed (all wipes except persist)? In case you still have problems with unlock try to disable ambient display always on (but keep active ambient on notification)
I did a clean install, flashed the baseband 1.7, and flashed magisk @sagope , and now everything works flawlessly. And I read about someone needing an updated version of twrp, but I did everything with my 3.0.something and nothing bad happened.
Thank you lads!
 

sagope

New Member
Nov 11, 2016
12
2
3
39
#19
Thank you @Mot Atlas, I'll flash magisk. And I'm going to change baseband again because when I reboot the phone I get an UI problem. And I have another problem with the alarm and this morning I didn't wake up! My recovery is TWR 3.1.1-0.
 

DiscoveryTeam

Administrator
Staff member
Apr 6, 2017
56
98
18
#20
Thank you @Mot Atlas, I'll flash magisk. And I'm going to change baseband again because when I reboot the phone I get an UI problem. And I have another problem with the alarm and this morning I didn't wake up! My recovery is TWR 3.1.1-0.
Use google clock from playstore. Confirmed that preinstalled clock is bugged (updated in OP)