RadioModem / Basebands Z2 Pro only

Jun 15, 2018
10
0
1
Excuse me, I'm a little noob. What Radio Modem/Baseband is for?
I'm updating from RR 6.1 to RR 6.2.1 and I'm reading about a lot of issues with Wi-Fi and Bluetooth in this Rom Version, does flashing a new Radio Modem/Baseband correct this? I can flash any baseband or depends on the Android Version?
 

MRDA

Active Member
Mar 18, 2017
407
95
28
mrda.wordpress.com
Had to open up phone to change the battery over the weekend; since then, I've noticed the phone can only sustain a 3G/H+ signal. I've tried the fix cited in the first post several times, and I've tried flashing several basebands several times, all to no avail. At best, after trying the fastboot fix, I get the 4G to hold for a few seconds at start up before it drops back to 3G.

I noticed three tiny gold clips falling around whilst changing the battery and suspect this has something to do with it. That said, the problem persist even after replacing the missing ones with those from another phone.

So, any idea what could be causing this?
 

mggiomix

New Member
Oct 16, 2019
12
0
1
I have installed all the latest versions of the modems listed in this thread but the problem has not been solved. Especially when they are indoors, the signal is lost and the connection is also completely absent and the phone is completely unusable. Do you have solutions that can solve the problem permanently? which custom rom install?
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
I have installed all the latest versions of the modems listed in this thread but the problem has not been solved. Especially when they are indoors, the signal is lost and the connection is also completely absent and the phone is completely unusable. Do you have solutions that can solve the problem permanently? which custom rom install?
seems more a hardware issue here.
Did you replace battery already? If you did maybe a connector of antenna is not fixed properly.
Check antenna and antenna connection inside.

Gesendet von meinem ZUK Z2121 mit Tapatalk
 
Likes: mggiomix

brokkon

New Member
Sep 29, 2017
17
0
1
I have installed all the latest versions of the modems listed in this thread but the problem has not been solved. Especially when they are indoors, the signal is lost and the connection is also completely absent and the phone is completely unusable. Do you have solutions that can solve the problem permanently? which custom rom install?
Maybe you have a hardware issue as said by weimerd. I think my problem was the same. "Fortunately", I broke my phone before the bad spirit. Back to xiaomi ;-)
 

mggiomix

New Member
Oct 16, 2019
12
0
1
it's strange because when I'm in an open environment the phone works properly. I didn't change the battery. I never changed the battery
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
it's strange because when I'm in an open environment the phone works properly. I didn't change the battery. I never changed the battery
maybe only your operator changed something at your station? I mean: maybe it is not the phone that changed but your operator did something?

Gesendet von meinem ZUK Z2121 mit Tapatalk
 

mggiomix

New Member
Oct 16, 2019
12
0
1
maybe only your operator changed something at your station? I mean: maybe it is not the phone that changed but your operator did something?

Gesendet von meinem ZUK Z2121 mit Tapatalk

I changed operator to virtual operator but the same sim card on another phone works very well
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
I changed operator to virtual operator but the same sim card on another phone works very well
well, then you could try:

Flash ZUI 1.9 using qfil.
Update to latest ZUI.
Check signal on latest ZUI then.

If it is still bad then it seems to be a hardware problem of your phone. I would point to the antenna cable.

For flashing ZUI 1.9 and update to latest ZUI see instructions on forum ;)

Gesendet von meinem ZUK Z2121 mit Tapatalk
 

mggiomix

New Member
Oct 16, 2019
12
0
1
well, then you could try:

Flash ZUI 1.9 using qfil.
Update to latest ZUI.
Check signal on latest ZUI then.

If it is still bad then it seems to be a hardware problem of your phone. I would point to the antenna cable.

For flashing ZUI 1.9 and update to latest ZUI see instructions on forum ;)

Gesendet von meinem ZUK Z2121 mit Tapatalk

I'll let you know as soon as it's done. thanks to you
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
after following your advice and using and flashing the phone this will not turn on anymore. do you have any advice to give me to recover the mobile at least to turn it on. thanks
usually flashing ZUI 1.9 using qfil following the instructions is THE absolute recovery solution.
So please follow the steps again.
If you can't manage to get into EDL mode just start qfil, load ZUI 1.9, connect your phone by usb and press and hold power button. It may take up to three minutes for EDL mode to show up on qfil. As soon as it shows you may release power button and press download button in qfil.


Gesendet von meinem ZUK Z2121 mit Tapatalk
 

mggiomix

New Member
Oct 16, 2019
12
0
1
usually flashing ZUI 1.9 using qfil following the instructions is THE absolute recovery solution.
So please follow the steps again.
If you can't manage to get into EDL mode just start qfil, load ZUI 1.9, connect your phone by usb and press and hold power button. It may take up to three minutes for EDL mode to show up on qfil. As soon as it shows you may release power button and press download button in qfil.


Gesendet von meinem ZUK Z2121 mit Tapatalk


it doesn't work and doesn't even go into recovery mode. the phone is bricked