[RECOVERY] Official TWRP for ZUK Z2 Pro

mar.ur

Active Member
Nov 9, 2017
394
133
43
#25
Strange behavior of the first twrp . I had 0mb of storage . I did format data and was ok. Storage 111 GB . I restarted to system and installed all my apps . Then went to TWRP and surprise - storage 0mb . I flashed the second Chinese TWRP and now is ok . I was using the previous version of this Chinese TWRP for some time and everything was ok . But I think we don't need that many partitions to backup and restore . I only restore system , data and boot (and firmware in case of Zui ) . It's enough to fully working backup

Sent from my ZUK Z2121 using Tapatalk
 

crisps

Well-Known Member
Aug 28, 2016
1,109
473
83
#27
Strange for me official twrp works for me....

Only aroma installer is upside down and hard to navigate... But its possible
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
#28
Strange for me official twrp works for me....

Only aroma installer is upside down and hard to navigate... But its possible
try flash CosmicOS. Make a full twrp backup. Then flash a different Rom like AEX. After that perform a full restore of Cosmic. Then you will realize the real bugs of that official twrp version.
In fact it gets stuck then on ZUK logo. No boot anymore. You need to perform a clean install again to make it work again. This is what I call NOT good ;)
 

crisps

Well-Known Member
Aug 28, 2016
1,109
473
83
#29
Hmm maybe its not related to twrp...
Did you tried other rom then aex??

Cosmic > full backup > flash e. g. LOS 14 > twrp restore???
 

mar.ur

Active Member
Nov 9, 2017
394
133
43
#30
Last times I switch between ROMs a lot . I restored my backups several times ( from Zui to custom rom , from Aex to Cosmic , from 8.1 to 7.1.2 etc) without any problems ( official TWRP ). But I restore only system, data and boot . But I think that some problems with backups could happen on various TWRP .
 

weimerd

ZUKFans Staff
Staff member
Sep 6, 2016
2,461
1,180
113
t.me
#31
Hmm maybe its not related to twrp...
Did you tried other rom then aex??

Cosmic > full backup > flash e. g. LOS 14 > twrp restore???
I got confirmation already from rom devs that there are bugs in last official twrp that explain the behaviour. So if you need to trust into your backups maybe switching to a more stable twrp version is suggested.
 

Cosme

Active Member
Jul 12, 2017
39
133
33
#35
New build:

* Add support for a pseudo-vendor partition (mount /factory as /vendor) which allows us to install ROMs with partial/full treble support.
* Fixup partitions sizes. Thanks to @DD3Boh.
* Update to O-mr1 based kernel (cosmedd/android_kernel_zuk_msm8996@e7c0a6c) which also fixes the Aroma installer upside down bug.

Due to the change in the size of the partitions you should redo your backups, if you have any.

Enjoy! ^_^
 

Cosme

Active Member
Jul 12, 2017
39
133
33
#36
New build:

* Add support for a pseudo-vendor partition (mount /factory as /vendor) which allows us to install ROMs with partial/full treble support.
* Fixup partitions sizes. Thanks to @DD3Boh.
* Update to O-mr1 based kernel (cosmedd/android_kernel_zuk_msm8996@e7c0a6c) which also fixes the Aroma installer upside down bug.

Due to the change in the size of the partitions you should redo your backups, if you have any.

Enjoy! ^_^
Forget this. TWRP made an invalid build without vendor support.

This build: https://github.com/cosmedd/android_...eases/download/20180311/20180311_recovery.img

It's the one that was supposed to be official.
 

greedy

Active Member
May 27, 2017
203
74
28
#37
Thanks for the 3.2.1.1 update !

Backups seem now to take a much longer time (about half an hour), it was taking 8 minutes before with 3.2.1.0.
 
Last edited: