ROM CUSTOM AEX 6.1/6.2/6.3 OFFICIELLE 9.0 POUR Z2 PRO

zuldar

Active Member
May 29, 2017
143
63
28
#41
Mdr, @Guyllheaume , j'avais eu le même problème et c'est ton post sur le baseband qui m'avait dépanner.... mdr... désolé ne pas avoir était connecté j'aurais pu t'aiguiller avec ton propre post effectivement ^^
 
Likes: Guyllheaume

moh2s

New Member
Jun 20, 2017
5
0
1
#42
Bonjour à tous,
Quelqu’un peut-il nous faire un retour sur l'appareil photo dans cette nouvelle version? Est-elle suffisante ou faut-il installer l'application google camera à part?
 

Guyllheaume

Well-Known Member
Jul 27, 2016
597
284
63
PARIS
#43
Bonjour à tous,
Quelqu’un peut-il nous faire un retour sur l'appareil photo dans cette nouvelle version? Est-elle suffisante ou faut-il installer l'application google camera à part?
Hello, je n'ai testé que rapidement l'appareil photo de la Rom et il ne m'a pas convaincu par rapport à la Gcam. Après c'était un essai rapide dans des conditions pas idéales.
 
Likes: moh2s

Altau

Active Member
Dec 1, 2017
154
32
28
Paris
#47
Donc, si je comprends bien, mon TWRP 3.2.3.0 que j'avais doit être remplacé par le 3.2.3-factory si on veut passer en AEX 6.3 ?

Ensuite, je ne trouve pas claires les indications données sur XDA. Faut-il faire autre chose qu'une MàJ de TWRP pour avancer ?
 

Kmar0

Active Member
Nov 25, 2017
200
57
28
#48
moi je fais la mise à jour comme décrit sur xda. Après je sais pas s'il existe d'autres twrp. Je ne vois pas pourquoi davidevinavil veut revenir sur le factory mais il est bien dis que cette mise à jour par le nouveau Twrp va englober aussi bien les ROMS en treble que non Treble.

Moi tant qu'elle fait l'affaire :)....Mais j'avoue que que tél fonctionne parfaitement depuis la dernière mise à jour (je parle pas de celle de maintenant 6.3 hein!)
 

Altau

Active Member
Dec 1, 2017
154
32
28
Paris
#49
Je viens d'installer TWRP factory 3.2.3 mais quand je le lance, il affiche 3.2.3.0 :rolleyes:
J'ai ensuite installé les gapps nano à la dernière version.
Je peux faire la mise à jour vers 6.3 sans risque ?
 

Guyllheaume

Well-Known Member
Jul 27, 2016
597
284
63
PARIS
#51
moi je fais la mise à jour comme décrit sur xda. Après je sais pas s'il existe d'autres twrp. Je ne vois pas pourquoi davidevinavil veut revenir sur le factory mais il est bien dis que cette mise à jour par le nouveau Twrp va englober aussi bien les ROMS en treble que non Treble.

Moi tant qu'elle fait l'affaire :)....Mais j'avoue que que tél fonctionne parfaitement depuis la dernière mise à jour (je parle pas de celle de maintenant 6.3 hein!)
Hello,

En effet cette modification de repasser sur le factory a son importance.
-L'utilisation de la partition Vendor (factory2vendor) était pratique dans le début des Customs Treble mais ce n'est pas sa partition normale. Il est censé être sur factory.
-Ca permettra d'utiliser le même TWRP pour toutes les Roms, Customs et Stock, ce qui n'est pas le cas actuellement
-J'imagine qu'à terme ça permettra aussi une meilleure intégration des GSI dans les différentes Custom Roms.
 
Sep 4, 2017
13
1
3
#52
Alors quand je flash le vendor2factory, la première ligne du terminal me dit en rouge :

Failed to mount '/vendor' (Invalid argument)

Et 6.3 refuse de s'installer au moment de "Patching vendor image unconditionally" forcément ...

Du coup pour tester j'ai remis "factory2vendor". Et même problème 6.3 ne se patch pas.

(j'ai flashé le TWRP dispo sur forum xda avant les manips)

Du coup j'ai re-flashé 6.2. J'ai toujours la ligne rouge "failed to mount /vendor", mais au moins la procédure va jusqu'au bout.
Par contre, au reboot, je reste sur l'icône AEX et son cercle qui tourne indéfiniment ...

Bref, j'avais réussi à éviter les conneries jusque là, mais ce coup ci c'est raté !

EDIT : après de trèèèèès longues minutes angoissantes, je suis de retour sur mon launcher ... mais il est stock et non plus comme je l'avais rangé ! Mes apps apparaissent toujours dans le panneau coulissant, mais quand je clique dessus elles ne se lancent pas et j'ai le message " ** s'arrête automatiquement" et les choix Infos / Fermer / Envoyer commentaires / Copier URL fichier de crash.
. Bref c'est pas résolu ...
 
Last edited:

Guyllheaume

Well-Known Member
Jul 27, 2016
597
284
63
PARIS
#53
Alors quand je flash le vendor2factory, la première ligne du terminal me dit en rouge :

Failed to mount '/vendor' (Invalid argument)

Et 6.3 refuse de s'installer au moment de "Patching vendor image unconditionally" forcément ...

Du coup pour tester j'ai remis "factory2vendor". Et même problème 6.3 ne se patch pas.

(j'ai flashé le TWRP dispo sur forum xda avant les manips)

Du coup j'ai re-flashé 6.2. J'ai toujours la ligne rouge "failed to mount /vendor", mais au moins la procédure va jusqu'au bout.
Par contre, au reboot, je reste sur l'icône AEX et son cercle qui tourne indéfiniment ...

Bref, j'avais réussi à éviter les conneries jusque là, mais ce coup ci c'est raté !

EDIT : après de trèèèèès longues minutes angoissantes, je suis de retour sur mon launcher ... mais il est stock et non plus comme je l'avais rangé ! Mes apps apparaissent toujours dans le panneau coulissant, mais quand je clique dessus elles ne se lancent pas et j'ai le message " ** s'arrête automatiquement" et les choix Infos / Fermer / Envoyer commentaires / Copier URL fichier de crash.
. Bref c'est pas résolu ...
Je pense que c'est parce que tu as procédé à l'envers entre vendor2factory et flash TWRP. Mais du coup je suis paumé sur l'état actuel de ta config.
L'ordre à suivre c'est :
-flash factory2vendor
-Update du TWRP
-REBOOT sur le TWRP
-Flash de la Rom et des Gapps.

Maintenant je pense que ça a quand même dû passer sinon ça ne marcherait pas du tout, par contre tu vas peut-être devoir faire un wipe des datas en plus du system et du cache/dalvik si tu as des FC en pagaille.
 
Sep 4, 2017
13
1
3
#54
Oui je viens de faire ça, wipe data et flash clean de 6.2 et des Gapps.
(c'est quoi des FC ?)

Par contre je peux pas "démettre à jour" mon TWRP nan ?
Du coup pour passer en 6.3 à partir de maintenant c'est quoi la procédure pour moi ?

Pfff mon 6.2 marchait au poil, le mieux est l'ennemi du bien j'vous dit :D
 

Altau

Active Member
Dec 1, 2017
154
32
28
Paris
#55
J'avais flashé factory2vendor il y a presque un an déjà.

Là, je viens de procéder à la mise à jour vers 6.3 en OTA et TWRP ne poursuit pas tout seul l'opération comme d'habitude.
Echec avec erreur 7
Divers messages d'erreur.
Ça reboote puis AEX démarre. Ça dure longtemps, comme à chaque changement de système, mais vraiment très longtemps, au point qu'au bout de 10mn, je reboote l'appareil pour repasser en 6.2.
A l'installation, message en rouge "échec du démontage vendor", au début et à la fin de l'installation de la 6.2.
Après 2 minutes, me revoilà en 6.2 qui semble tourner comme avant.
 

Altau

Active Member
Dec 1, 2017
154
32
28
Paris
#56
A présent, j'ai flashé vendor2factory, rebooté puis installé AEX 6.3.
L'installation ne génère pas d'erreurs.
On reboote sur AEX 6.3 et j'ai la main au bout de 2mn ! Comme avant, le code PIN de la carte SIM ne m'est pas demandé d'emblée. Suffit d'éteindre quelques secondes et de rallumer et tout est bon.
Je suis bien en 6.3 :)
 
Likes: Guyllheaume
Mar 12, 2017
30
8
8
#59
Ça va être plus compliqué de faire une vidéo que de faire la mise à jour ;)
https://forum.xda-developers.com/showpost.php?p=77439086&postcount=3

Si tu es sur une ROM avec /vendor (AEX depuis aout 2018 par exemple)
1. Flash Vendor2factory zip ( https://www.androidfilehost.com/?fid=673956719939835215 )
2. Flash le nouveau TWRP supportant /factory ( https://www.androidfilehost.com/?fid...63190603913222 )
3. IMPORTANT : Reboot sur le nouveau TWRP
4. Flash AEX 6.3
5. Pas besoin de wipe si tu était déjà sous AEX, sinon wipe cache+Dalvik (+ wipe data si c'est pas stable)

Si tu es sur une ROM avec /factory, passe directement à l'étape 2; après le flash de la ROM, flasher GApps...
 
Sep 4, 2017
13
1
3
#60
C'est bon j'ai réussi, mon zip vendor2factory ne devait pas être bon car avec le nouveau tout s'est passé sans souci !

A priori à partir de maintenant y'aura plus de blagues lors de mise à jour, genre plus besoin de changer des partitions etc .. ?
 
Last edited: