ROM CUSTOM AEX5.1 OFFICIELLE 8.1 POUR Z2 PRO

Mar 19, 2018
85
20
8
France 95
Hello,
quand je branche l'usb du Zuk, j'ai débogage usb activé, c'est tout.
Si je comprends j'applique la même méthode que pour installer le baseband
donc téléchargement des dernières versions sur les deux liens suivant
http://opengapps.org/ et https://downloads.aospextended.com/z2_row/
envoi sur le ZUK via bluetooth (je l'ai retrouverai dans download du TWRP comme pour le baseband)
et installation?
 

Guyllheaume

Well-Known Member
Jul 27, 2016
553
266
63
PARIS
Du coup ça vient peut-être des pilotes qui ne sont pas installés et qui empêchent ton téléphone d'être reconnu. Je ne me souviens plus où ça se trouve, mais probablement quelque part ici.
Si tu télécharges depuis le Zuk directement, oui ce sera dans Download. Si tu télécharges depuis le PC puis envoie en bluetooth, ce sera dans le dossier bluetooth.
-Pour l'installation, oui même principe, seulement il est mieux avant de procéder à l'installation de faire les effacements (wipes) de rigueur (cache, dalvik et system au minimum, parfois data également). Le wipe des datas efface les applis et leurs réglages, ainsi que tes paramétrages (wi-fi etc), mais pas tes fichiers médias.
Pour les Gapps, je conseille les Pico. Architecture : ARM64 - Version : 8.1
 

Guyllheaume

Well-Known Member
Jul 27, 2016
553
266
63
PARIS
Oui, grâce au TWRP. Il faut aller dans Backup, et choisir Data (de mémoire).
Puis une fois tout installé proprement, aller dans Restore et restaurer les datas.
 
Mar 19, 2018
85
20
8
France 95
un petit up pour signaler qu'à la fin de la charge du Zuk une petite fenêtre s'est ouverte me donnant la possibilité de faire des transfert de fichiers par usb
Bon je récupère mes photos et je me lance, je croise les doigts:D et je te tiens au courant
 
Likes: Guyllheaume
Mar 19, 2018
85
20
8
France 95
bon opération faite,
j'ai suivi la procédure, j'ai allumé mon tel avant de faire un restore des datas dans TWRP et j'ai eu comme message

Android System
there's an internal problemwith your device.
contact your manufacturer for details.

ensuite un autre message
Not Signed in
to use this phone, you first have to sign...

je suis donc revenu sur TWRP j'ai fait un restore des datas, rallumé le Z2 et j'ai eu à nouveau le premier message mais en français cette fois si mais pas le deuxième message.

sinon, j'ai retrouvé toutes mes applis, mais je suis toujours en H+ et pas en 4G
 

Guyllheaume

Well-Known Member
Jul 27, 2016
553
266
63
PARIS
bon opération faite,
j'ai suivi la procédure, j'ai allumé mon tel avant de faire un restore des datas dans TWRP et j'ai eu comme message

Android System
there's an internal problemwith your device.
contact your manufacturer for details.

ensuite un autre message
Not Signed in
to use this phone, you first have to sign...

je suis donc revenu sur TWRP j'ai fait un restore des datas, rallumé le Z2 et j'ai eu à nouveau le premier message mais en français cette fois si mais pas le deuxième message.

sinon, j'ai retrouvé toutes mes applis, mais je suis toujours en H+ et pas en 4G
Pour le message, c'est normal, il ne faut pas y faire attention. Pour la 4G, c'est bizarre
 
Mar 19, 2018
85
20
8
France 95
encore moi , je sais, j'ai le rôle du boulet:D mais j'assume
j'ai eu un signalement
qu'il y avait une mise à jour de magisk, j'ai, par l'appli téléchargé le fichier zip, je suis allé sur TWRP, install, et je me retrouve devant un tel qui ne s'allume plus (seul la led bleu visible).
je suis revenu sur TWRP, et je vais quoi maintenant?
 

Guyllheaume

Well-Known Member
Jul 27, 2016
553
266
63
PARIS
Ah, alors rien de méchant, mais il va te falloir un ordi. Il faut que tu télécharges ce fichier Magisk là : https://forum.xda-developers.com/attachment.php?attachmentid=4465065&d=1522707457
Que tu le glisse dans ta mémoire interne et que tu l'installe dans le TWRP. Avec les dernières modifs, la version officielle de Magisk n'est pas compatible. Le problème sera résolu à la prochaine mise à jour
 
Dec 1, 2017
100
16
18
Paris
Je confirme, cette version du 17/04 pose des problèmes (bizarre qu'elle ait été mise en ligne).
Je repasse sur la V5.4 du 11 avril qui tourne bien.

Mais je conserve malgré tout le message provoqué par la MàJ : "Google a cessé de fonctionner".
NE FAIRE CETTE MISE A JOUR DU 17 AVRIL QUE SI VOUS AVEZ SUIVI LES INSTRUCTIONS DE Guyllheame CI-DESSOUS A 10:06 PM
 
Last edited:
Likes: FARGO
Mar 30, 2017
105
18
18
Je confirme, cette version du 17/04 pose des problèmes (bizarre qu'elle ait été mise en ligne).
Je repasse sur la V5.4 du 11 avril qui tourne bien.

Mais je conserve malgré tout le message provoqué par la MàJ : "Google a cessé de fonctionner".
Faut wipe tout
 

Guyllheaume

Well-Known Member
Jul 27, 2016
553
266
63
PARIS
Les gars, j'ai suivi les recommandations de Davide sur le fil XDA de la Rom et j'ai eu aucun soucis.

Voilà les étapes à suivre :
1 Télécharger le fichier factory2vendor.zip (f2v.zip)
2 Télécharger le dernier TWRP de CosmeDD (officiel) en date du 13/04.
Les deux liens sont aussi dispos en premier post de ce fil
3 Télécharger la Rom AEX du jour (17/04) - Devrait marcher pour les suivantes également.
3bis Télécharger les Gapps de votre choix si vous n'en avez pas en mémoire
4 Au cas où, un back-up des données si ça vous rassure, mais j'ai tout installé sans effacer les datas et aucun problème pour l'instant.

Maintenant qu'on est bordés :
-1 Reboot sur le TWRP
-2 Flash du zip Factory2vendor.zip (j'ai wipé cache et dalvik avant et après, je ne sais pas si c'était utile).
-3 Flash du nouveau TWRP - Ne pas oublier que c'est un fichier .img, donc il faut changer la recherche dans "install".
-4 Reboot sur le TWRP (depuis le menu principal > Reboot > Recovery NE SURTOUT PAS REBOOTER SUR LE SYSTÈME
-5 Wipe cache/dalvik/system
-6 Install AEX + Gapps.
-7 Wipe Cache/dalvik.
-8 Reboot System
Et pour ceux qui rootent, une fois le système lancé une première fois :
-9 Téléchargement Magisk 16.0 officiel
-10 Reboot sur le TWRP
-11 Flash Magisk
-12 Wipe Cache/dalvik
-13 Reboot System.

On y est !

Je pense que cette mise à jour était la plus galère, les suivantes seront plus simples.
Quoiqu'il en soit... Maintenant on a un support Treble complètement opérationnel.

Merci à Davide, Cosme et aux autres pour leur job.
Tous les crédits vont aux développeurs respectifs, j'ai simplement traduit et détaillé les différentes étapes pour procéder.
A+
 
Last edited: