MOD U Health (standalone zip)

witty

New Member
Jun 29, 2017
11
1
3
#42
When i try to login with my acount, the phone say "Served not responded, tplease ry again later".
What's it de problem? help me.
 
Aug 15, 2017
38
8
8
#44
When i try to login with my acount, the phone say "Served not responded, tplease ry again later".
What's it de problem? help me.
I had the same problem and finally got it working.
Make sure you granted all permissions to u-health app.
Go to Lenovo website and create a new account, you will have to use different email.
It worked for me.

Enviado desde mi ZUK Z2121 mediante Tapatalk
 
Jan 10, 2018
32
14
8
#45
I had the same problem and finally got it working.
Make sure you granted all permissions to u-health app.
Go to Lenovo website and create a new account, you will have to use different email.
It worked for me.
Your solution means that all data from previous account will be lost for you.
I had similar problem. I made clean installation on stock, checked U-Health - it worked. So after i install back custom Android and U-health started work with my original login. Probably you can try "wipe data" and try to use it. But don't forget to make backup.
 
Aug 15, 2017
38
8
8
#46
I don't use the u-health app very often and of course, I don't care about data.
I have it just for the heart rate sensor.
I tried to wipe data. Even wiped /system and it still not working.
So with new account it works. For me it's ok.

Enviado desde mi ZUK Z2121 mediante Tapatalk
 
Jan 10, 2018
32
14
8
#48
Finally I have working U-Health on AEX 5.2.
So, I used "cosme port" and apk files from zui 3.5.259st: U-Health, LSF_device and LSF_user.
First of all I made full backup of system and files that changed by "cosme port".
Installed "cosme port" by TWRP
Start OS -> give all permissions for U-Health, LSF_device and LSF_user apk.
Replaced U-Health apk on new version from 3.5.259.
In TWRP replaced buckuped files of AEX in lib, lib64, bin folders.
U-Health started, Lenovo account sync.
Pedometer works without problem.
Heartrate sensor - works but not correct: started flashlight and camera instead of heartrate sensor.

So i hope smbd could confirm it. Anyway, i'm not sure that it will 100% work.
 

Attachments