Z2 plus not charging

karachun

New Member
Oct 28, 2017
8
0
1
I buy chip cx64 and replace, it dont work. Battery drain 11% to 0% ....
either i have added a lot of flux or something is wrong with the mboard.

the one who writes that the replacement of the chip helped them, it is simply deceiving. The replacement did not help me, the battery does not charge. I charged the battery with a lab power supply. supplied power to 4.40V as written on batteries, although another 3.80 is written on baterry.
I also changed the socket on the motherboard for the battery plume
...

also the phone does not see the PC, what can it be? where might be the problem?
how to find a short circuit, who in the know?
Someone take a photo in an enlarged view where the battery cable is connected plug on the motherboard. Take an enlarged photo of the cx chip mounting!
 
Last edited:
Dec 6, 2017
3
0
1
I've got the same problem. I connected it to a Qualcomm QC 3.0 power bank and it stopped charging. Now when i try to charge it it gets really hot and doesn't charge. If I remove the chip will the phone work again?
 

devjin

New Member
May 4, 2017
1
1
3
I can confirm that removing the cx64 chip fixes the charging problem. I just finished fixing my Z2 charging. Thanks to whoever discovered this neat trick.
 
Likes: yaskyy

0gopogo

New Member
Jun 22, 2017
2
0
1
I had the same charging loop whenever the phone was a 0% power. I followed galileo13's instructions and my Z2 now (slow) charges again. Seemed strange but it's true. Works. Thanks, g13
 
Feb 3, 2019
1
0
1
i followed to remove cx 64 chip, but still doesn't work, any suggestion ? pls help me, i already changed the many cable, adaptor but stil can't charge
 

stathis

New Member
Mar 3, 2019
1
0
1
Not being able to charge the phone just happened to me 2 days ago. I left the phone on the charger for 1 day but nothing happened(sometimes there was a 0% battery on display).Today i put it on the pc usb3 , and after many plug ins 'n outs and many boot button pushes, it began to charge and phone opened at 6% battery..
Now sometimes the charging works, sometimes not...