ZUK Z2 plus bricked

Nov 27, 2018
3
0
1
#1
I am a zuk z2 plus user since 2017 using a modified rom zui 2.0.43 multilanguage with greek language from Franco76.
Yesterday I wanted to update to oreo version with custom rom via TWRP recovery. Before that I had saved a NANDROID backup (having clicked compression during backuping)
I didn't like the new rom so I tried to restore Nandroid with my updated TWRP 3.2.1.0 and it showed a verification problem after restoring. So I thought it has to do with wrong TWRP version. Then I tried to downgrade to TWRP 3.0.3 and wiped everything except from internal storage. After flashing the new TWRP version I restarted to recovery mode, and it dissapeared :'(
Now I have only fastboot mode with device state-unlocked. It doesn't boot to twrp anymore. And I dont have a software to start the phone. And I don't know what to do. Could you help me please?
 

ivass

Active Member
Mar 11, 2017
206
35
28
Brussels/Sofia
#2
You need to flash stock zui rom. I suggest you to do qpst flash. Start with Chinese 1.9 ROM which will relock your bootloader. After that if you want to skip ota updates flash zui 3.5 qpst. Which will update your bootloader and make it capable to run treble roms and anything new. After you do this you have to start over with unlocking bootloader and then flashing treble twrp and then your favorite ROM. Advice from Bulgaria. Good luck.

Sent from my ZUK Z2131 using Tapatalk
 
Nov 27, 2018
3
0
1
#3
Thank you for your reply my dear neighbor :)
Actually I have tried to flash the stock qpst zui 1.9 but it constantly shows that annoying "sahara error"
I have tried with three different computers both windows 7 and windows 10 , again that sahara error...
Do you know any way to save my internal memory files? I have important files inside.
Also I have tried with minimal adb to flash the TWRP but the cmd doesn't recognize my device when I type "adb devices" even if I reinstall the shenQi adb drivers. A total dissaster. If I finally flash with qfil will my internal memory personal files be lost?