Zuk Z2 Pro - IMEI Wiederherstellung / Re-write

DerSven

New Member
Aug 22, 2018
10
0
1
#1
Hallo zusammen,

ich habe ein großes Problem, seit Wochen: Besitze zwei Zuk Z2 Pros und habe beide beim Flashen "gebrickt". Durch QFIL habe ich nun eines mit ZUI 3.5 (Android 8 / Standard ROM, kein root) und einmal die Mokee Variante in 7.1, mit root.

Beide Smartphones haben aber die IMEIs und die MEID verloren. Versuche nun schon seit Wochen mit den Anleitungen aus dem Web diese zu "schreiben". Ob das die Tools für Dual Write IMEI sind, die Qualcomm Tools oder mit QFIL Configuration, alle schlagen fehl. Ich bekomme nicht mal im Netz die Info, ob die Tools mit dem MSM8996 Snapdragon 820 klar kommen?

Derzeit schaffe ich es nur augenscheinlich mit dem Mokee über adb shell, su, setprop sys.usb.config diag(,adb) in den Diag Mode 900E zu kommen, wie alle schreiben. Windows richtet hierfür dann auch den Qualcomm HE Diagnostic Port (COM x) unter Anschlüsse (Ports und COM) ein.

Aber alle Tools sagen am Ende "Fail", wenn es um das Schreiben der IMEIs geht.

Mit dem ZUI 3.5 schaffe ich es gar nicht. Zwar kann ich den 9008er Mode aktivieren, aber damit kann ich keine IMEIs schreiben.

Ich möchte nur ungern die Geräte in die Ecke legen. Sie sind auch heute einfach noch top. Die Frage ist nun, was kann ich machen? Bin echt am Verzweifeln, da ich schon Tage versenkt habe und kein Stück weiter bin.

Würde mich über Hilfe und Tipps freuen. Danke vorab!

Viele Grüße Sven
 

DerSven

New Member
Aug 22, 2018
10
0
1
#3
Die Anleitungen hier schauen ganz vielversprechend aus

https://www.digitbin.com/restore-lost-imei-number-android/
Hi Groo!

Danke für deine Antwort. Auf eine ähnliche Anleitung bin ich auch bereits gestoßen. Diese funktionieren aber nicht bei einem Snapdragon Prozessor. Die Steuerbefehle werden nur auf MediaTek Proozessoren verarbeitet. Bei dem Qualcomm Snapdragon passiert gar nichts. Leider! :-(

Angeblich wäre es ja so leicht auf einem Qualcomm IMEIs neu zu schreiben. Nur klappt es einfach nicht. Weiß eben nicht, was ich falsch mache.
 

DerSven

New Member
Aug 22, 2018
10
0
1
#5
Naja, wenn du mit QFIL das ROM drauf bekommen hast sollte es mit dem Prozessor schon klar kommen...

Meine Frage noch: Welches Windows benutzt du?
Windows 10 Pro im Testmodus, damit er auch problemlos die unsignierten Treiber akzeptiert.
 

Groo

Active Member
Jun 6, 2017
227
48
28
Germany, Bavaria
#6
Wenn ich mich richtig erinnere gibt es Probleme mit QFIL und Windows 8 & 10...
Hast du ne Möglichkeit das alles mal auf nen Rechner mit Windows 7 zu machen?
 

DerSven

New Member
Aug 22, 2018
10
0
1
#7
Wenn ich mich richtig erinnere gibt es Probleme mit QFIL und Windows 8 & 10...
Hast du ne Möglichkeit das alles mal auf nen Rechner mit Windows 7 zu machen?
Leider nicht so richtig, ohne großen Aufwand. PC und Laptop sind beides Windows 10. :-/
 

crisps

ZUKFans Staff
Staff member
Aug 28, 2016
1,049
459
83
#8
Wenn ich mich noch erinnern kann,
Es gab mal jemanden hier, der hatte das gleiche Problem...
Hat hier im forum auch um Hilfe gebeten.
Hat ein tutorial geschrieben um die IMEI zu backupen....

Hat bei mir nicht funktioniert....
QPST hat nie Zugriff bekommen...
Set prop irgendwas ging auch nicht....

Ich habe windows 7
 

DerSven

New Member
Aug 22, 2018
10
0
1
#10
Morgen crisps,

danke dir für deine Antwort. Kann ich mal die nächsten Tage ausprobieren. Am WE werde ich jetzt leider nicht dazu kommen. Allerdings bin ich gespannt, weil ähnliche Befehle in Kombination mit "diag," haben bisher nicht funktioniert:

setprop sys.usb.config diag,rmnet,adb
setprop sys.usb.config diag,acm_smd,acm_tty,rmnet_bam,mass_storage,adb

Ich lass mich mal überraschen und gebe Bescheid. Hoffentlich klappt es, da ich sonst auch keine Ahnung mehr habe. Nach deiner vorherigen Ausführung wären die Geräte dann nur noch für den Schrank oder Elektro-Kleinschrott nützlich. :-(


Gruß
Sven
 

Groo

Active Member
Jun 6, 2017
227
48
28
Germany, Bavaria
#11
@DerSven hast du schon mal versucht komplett auf Stock zu gehen?
Via QFIL auf ZUI 1.9, Baseband flashen?

Hab hier im Forum gelesen das wohl auf wundersame Art und Weise die IMEI´s beim flashen verschiedenster ROMs wieder erschienen...??? :oops:
 

DerSven

New Member
Aug 22, 2018
10
0
1
#12
@DerSven hast du schon mal versucht komplett auf Stock zu gehen?
Via QFIL auf ZUI 1.9, Baseband flashen?

Hab hier im Forum gelesen das wohl auf wundersame Art und Weise die IMEI´s beim flashen verschiedenster ROMs wieder erschienen...??? :oops:
Jap, die 1.9 ZUI habe ich als Ausgangslage genutzt, damit bspw. das ZUK wieder "unrootet" wird. Habe bereits vom "brick" aus in 1.9, 2.1, 2.3, 2.5 und 3.1 geflasht. Aber bei keiner Version hatte ich am Ende eine IMEI für eine der Slots. :-/

Theoretisch kann ja auch nicht mit dem Rom eine IMEI kommen. Theoretisch! Denn diese weicht ja von Gerät zu Gerät ab. Daher ja auch die Qualcomm Tools zum Beschreiben. Nur findet keines das Phone.

Ganz ehrlich: Weiß auch nicht, was ich noch machen kann. :-(
 

Groo

Active Member
Jun 6, 2017
227
48
28
Germany, Bavaria
#13
Da muss es doch ne Lösung geben...!
Hast du mal ein anderes USB-Kabel verwendet bzw nen anderen USB-Port? Damit hatte ich auch schon Probleme.
Wenn du willst kannst du es mir mal schicken und ich versuche es auf meinem Laptop, da läuft Win7.
 

crisps

ZUKFans Staff
Staff member
Aug 28, 2016
1,049
459
83
#14
Wie gesagt.... Habe icb mein Z2 pro auf Win7 nicht in den modus gebracht damit qualcom tool ein Backup oder Flash macht fur IMEI...
 

Groo

Active Member
Jun 6, 2017
227
48
28
Germany, Bavaria
#15
Wie gesagt.... Habe icb mein Z2 pro auf Win7 nicht in den modus gebracht damit qualcom tool ein Backup oder Flash macht fur IMEI...
Echt komisch... Ich stolper immer wieder über die Aussagen das Leute mit Win 8 & 10 Probleme mit QFIL haben.
Evtl ne Alternative wäre ein defektes "Schlachthandy" aus dem das Mainboard getauscht wird.
Das sollte doch klappen, oder?