ZUK Z2 Pro - Impossible de passer en EDL via ADB

Jan 2, 2018
7
0
1
45
#1
Bonjour tout le monde,

En voulant passer mon Z2 Pro en AEX version 6.4, j'ai tout perdu...
Je m'explique.

J'ai voulu passer TWRP en factory, mais ça ne s'est pas bien passé.
J'ai eu la grande idée de supprimer tout ce que je stockai avant de charger la nouvelle version de TWRP.
Et pour finir j'ai relancer le smartphone...

Conclusion, j'ai plus rien dessus :(

J'arrive maintenant sur le bootloader qui me propose pas grand chose...

Je cherche a remettre une ROM stock via QFIL mais pour cela il faut que mon ZUK soit reconnu par mon pc et que je puisse lancer la commande "adb reboot edl"
Mais impossible..

Je dois certainement mal m'y prendre, est ce que quelqu'un a déjà eu le même souci ?

À moins que je puisse charger l'image TWRP directement ?

ps: J'ai tenté les techniques manuelles où tu dois éteindre le téléphone, appuyer le Volume + puis appuer sur Power et brancher le câble USB tout en maintenant le Volume +


Merci pour vos conseils :)
 
Jan 2, 2018
7
0
1
45
#2
Un peu plus de détails:

Actuellement quand je démarre le téléphone j'arrive sur le menu FASTBOOT MODE
On me propose:
Restart bootloader
Recovery mode
Power off
Boot to fbm
START

Quand je branche mon Zuk sur mon pc (Windows 10), il reconnait mon téléphone dans les périphériques en tant que "ShenQi ADB Device"

Si je lance la commande "adb reboot edl" il m'indique "error: device '('null)' not found"


Je ne sais plus quoi faire... :(
 

JEAN56

Active Member
Jul 28, 2017
648
199
43
#3
Salut.

Maintenant que tu en es la,as tu essayer de transférer (coller)de ton pc au zuk?
As tu essayé les options qui te sont proposées lors du demarrage?Et si oui qu'est ce que cela a donné?
 
Jan 2, 2018
7
0
1
45
#5
J'ai réussi à le réinstaller :)

Ce qui a débloqué la situation c'est l'application TOOL ALL IN ONE justement

J'avais bien le bon driver d'installer, mais mon ZUK n'était jamais détecté de manière à ce que je puisse transférer des choses dessus.

Je n'avais jamais utilisé l'outil TOOL ALL IN ONE encore donc en desespoir de cause j'ai installer.

le "model auto detect" ne marchai pas..

Je pensais être bloqué aussi, j'ai tenté sans y croire le bouton "Recovery Flasher and Root"
J'ai valider le "MANUAL MODE", cherché une image TWRP et fait flash.
Miracle j'avais TWRP :)

Par contre impossible de remettre une ROM ou un Backup via TWRP.
Il me faisait une erreur sur le \vendor
J'avais beau essayer de passer en Factory ou l'inverse, ça me faisait la même chose.

J'ai donc relancé QFIL et rechargé la ROM STOCK 1.9.104
passage en anglais
j'ai migré en versions 3.5.259ST
passage de l'usb en DEBUG
UNLOCK, chargement de TWRP 3.3

J'ai été bloqué à ce moment là, car je n'arrivai pas à monter mon ZUK en clé USB via cette version de TWRP.
Je n'avais pas accès aux partitions.
il me demandait en schéma pour dévérouiller, j'ai pas compris...

Je suis donc passé sur la version 3.23 de TWRP

J'ai chargé la AEX 6.5 avec le GAPPS Pico et Magisk 18.1 et tout était redevenu comme avant.

Tuto intéressant pour tout refaire quand on l'a pas fait depuis un certain temps:
https://zukfans.eu/community/thread...aospextended-rom-v6-0-z2-pro-4-4-kernel.8536/


J'étais bloqué depuis lundi soir :( . En parallèle je cherchais un nouveau smartphone qui vallait de le coup que j'arrète de chercher à réparer mon ZUL Z2 Pro.
Ne trouvant rien qui me fasse abandonner, j'ai persévérer ;)